Back to overview
Downtime
Omnibyte Technologies' global outage
Jun 12 at 09:12pm BST
Affected services
Drivers Hub
Public Site
Resolved
Jun 13 at 01:26am BST
Services are now stable.
Affected services
Drivers Hub
Public Site
Updated
Jun 12 at 09:47pm BST
Services are returning to normal and should be accessible. We are continuing to monitor.
Affected services
Drivers Hub
Public Site
Updated
Jun 12 at 09:37pm BST
We have identified the root cause of the issue and are gradually restoring services.
Affected services
Drivers Hub
Public Site
Created
Jun 12 at 09:12pm BST
We are aware of a global outage of all Omnibyte Technologies' services and working to bring them back as soon as possible.
Affected services
Drivers Hub
Public Site